Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/gettext/PKGBUILD3
-rw-r--r--core/libarchive/PKGBUILD8
-rw-r--r--core/pacman/PKGBUILD10
3 files changed, 19 insertions, 2 deletions
diff --git a/core/gettext/PKGBUILD b/core/gettext/PKGBUILD
index 5a2c876d..be7f41e3 100644
--- a/core/gettext/PKGBUILD
+++ b/core/gettext/PKGBUILD
@@ -10,3 +10,6 @@ eval "$(
if [ "${CARCH}" = "i486" ]; then
makedepends+=(icu73)
fi
+
+# currrenly broken around libsitter
+makedepends=(${makedepends[@]//emacs/})
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index 803046dd..56ede898 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -2,3 +2,11 @@
if [ "${CARCH}" = "i486" ]; then
sha256sums=(SKIP)
fi
+
+# ABI differences in libxml2, disable XAR
+eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --without-xml2 /
+ '
+)"
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 99b6a18e..61a6bf13 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -45,15 +45,17 @@ if [ "${CARCH}" = "i486" ]; then
fi
# If this still applies, it only does for i486:
-if [ "${CARCH}" = "i486" ]; then
+# (while not having Python, it's not working on any CARCH)
+#if [ "${CARCH}" = "i486" ]; then
# broken Python/asciidoc
eval "$(
declare -f build | \
sed '
/meson/s/-Ddoc=enabled/-Ddoc=disabled/
+ /meson/s/-DDdoxygen=enabled/-DDdoxygen=disabled/
'
)"
-fi
+#fi
# gettext is linked against old ICU verison on i486, use ICU 72 stub
if [ "${CARCH}" = "i486" ]; then
@@ -61,3 +63,7 @@ if [ "${CARCH}" = "i486" ]; then
fi
sha256sums[0]='SKIP'
+
+# fails happilly at the moment, going full risk now and installing it anyway..
+unset check
+unset checkdepends