Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-support/muon-meson/PKGBUILD6
-rw-r--r--build-support/muon-meson/disabled/PKGBUILD-minimal-static66
-rw-r--r--core/gettext/PKGBUILD3
-rw-r--r--core/libarchive/PKGBUILD8
-rw-r--r--core/pacman/PKGBUILD10
5 files changed, 87 insertions, 6 deletions
diff --git a/build-support/muon-meson/PKGBUILD b/build-support/muon-meson/PKGBUILD
index 7ff40b4c..6eb8ba82 100644
--- a/build-support/muon-meson/PKGBUILD
+++ b/build-support/muon-meson/PKGBUILD
@@ -29,8 +29,7 @@ build() {
msg2 "Building stage 2 (muon from bootstrap)"
build-stage1/muon setup \
-D docs=disabled \
- -D static=true \
- -D libpkgconf=disabled \
+ -D libpkgconf=enabled \
-D libcurl=disabled \
-D libarchive=disabled \
build-stage2
@@ -42,8 +41,7 @@ build() {
-D b_lto=false \
-D b_pie=false \
-D docs=disabled \
- -D static=true \
- -D libpkgconf=disabled \
+ -D libpkgconf=enabled \
-D libcurl=disabled \
-D libarchive=disabled \
build
diff --git a/build-support/muon-meson/disabled/PKGBUILD-minimal-static b/build-support/muon-meson/disabled/PKGBUILD-minimal-static
new file mode 100644
index 00000000..384250d7
--- /dev/null
+++ b/build-support/muon-meson/disabled/PKGBUILD-minimal-static
@@ -0,0 +1,66 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=muon-meson
+pkgver=0.3.1
+pkgrel=3
+pkgdesc="meson implementation in C"
+arch=(x86_64 pentium4 i686 i486)
+url="https://muon.build"
+license=(GPL3)
+source=(
+ "$url/releases/v$pkgver/muon-v$pkgver.tar.gz"
+ "arch-muon")
+sha256sums=('45f6ad728946a0788188004e3a88a77a7d07b48525ce0646430589d1db4c832e'
+ '4e507d5b129cd7de05aca972504ab06c2353b145e7378d15aa75b7d4b1b252e8')
+#depends=(pkgconf curl libarchive)
+depends=(pkgconf)
+#makedepends=(ninja python-yaml scdoc)
+makedepends=(ninja)
+checkdepends=(git)
+provides=(muon)
+
+build() {
+ cd "muon-v$pkgver"
+ rm -rf build*
+
+ msg2 "Building stage 1 (bootstrap)"
+ ./bootstrap.sh build-stage1
+
+ msg2 "Building stage 2 (muon from bootstrap)"
+ build-stage1/muon setup \
+ -D docs=disabled \
+ -D libpkgconf=disabled \
+ -D libcurl=disabled \
+ -D libarchive=disabled \
+ build-stage2
+ ninja -C build-stage2
+
+ msg2 "Building stage 3 (muon from muon)"
+ build-stage2/muon setup \
+ -D prefix=/usr \
+ -D b_lto=false \
+ -D b_pie=false \
+ -D docs=disabled \
+ -D libpkgconf=enabled \
+ -D libcurl=disabled \
+ -D libarchive=disabled \
+ build
+ ninja -C build
+}
+
+check() {
+ cd "muon-v$pkgver/build"
+ ./muon test || true
+}
+
+package() {
+ cd "muon-v$pkgver/build"
+ DESTDIR="$pkgdir" ./muon install
+
+ install -Dm775 "$srcdir/arch-muon" "$pkgdir/usr/bin/arch-muon"
+
+ # remove this as the `meson` package also provides it
+ # muon only has a `docs` option right now, so
+ # downloading/generating/deleting is the only option :/
+# rm "$pkgdir"/usr/share/man/man3/meson-reference.3
+}
diff --git a/core/gettext/PKGBUILD b/core/gettext/PKGBUILD
index 5a2c876d..be7f41e3 100644
--- a/core/gettext/PKGBUILD
+++ b/core/gettext/PKGBUILD
@@ -10,3 +10,6 @@ eval "$(
if [ "${CARCH}" = "i486" ]; then
makedepends+=(icu73)
fi
+
+# currrenly broken around libsitter
+makedepends=(${makedepends[@]//emacs/})
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index 803046dd..56ede898 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -2,3 +2,11 @@
if [ "${CARCH}" = "i486" ]; then
sha256sums=(SKIP)
fi
+
+# ABI differences in libxml2, disable XAR
+eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --without-xml2 /
+ '
+)"
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 99b6a18e..61a6bf13 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -45,15 +45,17 @@ if [ "${CARCH}" = "i486" ]; then
fi
# If this still applies, it only does for i486:
-if [ "${CARCH}" = "i486" ]; then
+# (while not having Python, it's not working on any CARCH)
+#if [ "${CARCH}" = "i486" ]; then
# broken Python/asciidoc
eval "$(
declare -f build | \
sed '
/meson/s/-Ddoc=enabled/-Ddoc=disabled/
+ /meson/s/-DDdoxygen=enabled/-DDdoxygen=disabled/
'
)"
-fi
+#fi
# gettext is linked against old ICU verison on i486, use ICU 72 stub
if [ "${CARCH}" = "i486" ]; then
@@ -61,3 +63,7 @@ if [ "${CARCH}" = "i486" ]; then
fi
sha256sums[0]='SKIP'
+
+# fails happilly at the moment, going full risk now and installing it anyway..
+unset check
+unset checkdepends