Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 15:31:35 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 15:31:35 +0200
commit75fd7dcb7e192d9e122c9d52ddf53d009392f9bd (patch)
treebca93450cbe2080de8c8c9a0b4b5f9ea60b0442c /community
parent238503a5a57423359dd7f9cbde4ca032fb526efc (diff)
community/rubygems: set PATH to find ruby in bootstrap, avoid installing ruby itself
Diffstat (limited to 'community')
-rw-r--r--community/rubygems/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/community/rubygems/PKGBUILD b/community/rubygems/PKGBUILD
index e4a5d80a..8d8a8156 100644
--- a/community/rubygems/PKGBUILD
+++ b/community/rubygems/PKGBUILD
@@ -1,12 +1,15 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
+# this means that 'ruby setup.py' is not found (must set PATH to bootstrap ruby)
makedepends=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
'
)"