Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 15:31:23 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 15:31:23 +0200
commit238503a5a57423359dd7f9cbde4ca032fb526efc (patch)
tree43730d12989a2dcb2f2e29efb3fb7a9a8592f6d0 /community
parentcba61b6ca2b08598bde7ae94feffa3128b93bd53 (diff)
community/rubygems: set PATH to find ruby in bootstrap, avoid installing ruby itself
Diffstat (limited to 'community')
-rw-r--r--community/rubygems/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/rubygems/PKGBUILD b/community/rubygems/PKGBUILD
new file mode 100644
index 00000000..e4a5d80a
--- /dev/null
+++ b/community/rubygems/PKGBUILD
@@ -0,0 +1,13 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+
+unset check