Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/rubygems/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/rubygems/PKGBUILD')
-rw-r--r--community/rubygems/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/rubygems/PKGBUILD b/community/rubygems/PKGBUILD
new file mode 100644
index 00000000..e4a5d80a
--- /dev/null
+++ b/community/rubygems/PKGBUILD
@@ -0,0 +1,13 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends=(ruby-bootstrap)
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+
+unset check