Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/rubygems/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/rubygems/PKGBUILD')
-rw-r--r--community/rubygems/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/community/rubygems/PKGBUILD b/community/rubygems/PKGBUILD
index e4a5d80a..8d8a8156 100644
--- a/community/rubygems/PKGBUILD
+++ b/community/rubygems/PKGBUILD
@@ -1,12 +1,15 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
+# this means that 'ruby setup.py' is not found (must set PATH to bootstrap ruby)
makedepends=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
'
)"