Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 20:37:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 20:37:59 +0200
commit6182e7af4cde97cbf8a0f242a29382c7055f7c63 (patch)
treedffadcb9a6ffc6d0875d17ca5cc452f15a2f18dc /community
parentb4fee7e3d23677ca94cbcfef28b7ecb9472c3170 (diff)
another ruby-rake thing
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD5
-rw-r--r--community/ruby-rake/PKGBUILD5
2 files changed, 4 insertions, 6 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index c24ebfd2..019e82a9 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,12 +1,11 @@
# no documentation during bootstrapping
makedepends=(${makedepends[@]//ruby-rdoc/})
-makedepends+=(ruby-bootstrap)
-
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- /_gemdir/ a mkdir -p "${pkgdir}"/opt/"${pkgname}-${pkgver}"
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 61f28512..013d5c83 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,9 +1,8 @@
-makedepends+=(ruby-bootstrap)
-
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- /_gemdir/ a mkdir -p "${pkgdir}"/opt/"${pkgname}-${pkgver}"
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"