Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 20:26:20 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 20:26:20 +0200
commitb4fee7e3d23677ca94cbcfef28b7ecb9472c3170 (patch)
tree99552c388120be3ef30836199a06ba7f43b192e7 /community
parenta91e8f5d99a18a9b17b0b0faeba80aed11663ec2 (diff)
and back to /opt
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD4
-rw-r--r--community/ruby-rake/PKGBUILD4
2 files changed, 6 insertions, 2 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index d2adfeaa..c24ebfd2 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,10 +1,12 @@
# no documentation during bootstrapping
makedepends=(${makedepends[@]//ruby-rdoc/})
+makedepends+=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/opt/"${pkgname}-${pkgver}"
'
)"
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 0cd466de..61f28512 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,7 +1,9 @@
+makedepends+=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/opt/"${pkgname}-${pkgver}"
'
)"