Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 20:46:42 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 20:46:42 +0200
commit5143f5413228abb384e81ac99b937a76df54dd6b (patch)
tree5936dae75cf73b60b95aa4038434b5c9fb1e876a /community
parent63f91427df5f4b54f498fa1153bae758e59beb1c (diff)
community/ruby: temporarily removed ruby-doc from ruby-stdlib (rubygems clash)
Diffstat (limited to 'community')
-rw-r--r--community/ruby/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/ruby/PKGBUILD b/community/ruby/PKGBUILD
index 530cd9f4..9a42864d 100644
--- a/community/ruby/PKGBUILD
+++ b/community/ruby/PKGBUILD
@@ -20,3 +20,14 @@ fi
if [ "${CARCH}" = "i486" ]; then
unset check
fi
+
+# temporarily remove ruby-rdoc (because of clashes with rubygems
+# (why rubygems should have /usr/bin/rdoc and /usr/bin/ri in it
+# is a miracle to me though?!)
+eval "$(
+ declare -f package_ruby-stdlib | \
+ sed '
+ /depends/ a \
+ depends=(${depends[@]//ruby-rdoc/})
+ '
+)"