Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby/PKGBUILD')
-rw-r--r--community/ruby/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/ruby/PKGBUILD b/community/ruby/PKGBUILD
index 530cd9f4..9a42864d 100644
--- a/community/ruby/PKGBUILD
+++ b/community/ruby/PKGBUILD
@@ -20,3 +20,14 @@ fi
if [ "${CARCH}" = "i486" ]; then
unset check
fi
+
+# temporarily remove ruby-rdoc (because of clashes with rubygems
+# (why rubygems should have /usr/bin/rdoc and /usr/bin/ri in it
+# is a miracle to me though?!)
+eval "$(
+ declare -f package_ruby-stdlib | \
+ sed '
+ /depends/ a \
+ depends=(${depends[@]//ruby-rdoc/})
+ '
+)"