Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 19:18:43 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 19:18:43 +0200
commit63f91427df5f4b54f498fa1153bae758e59beb1c (patch)
tree2c5840b95dae574d5be68156ea91bf8c3925ffb9 /community
parent8da98728a98fa4e6e0b777cc218d07fd72431ce3 (diff)
community/rubygems: rebuilding using ruby instead of bootstrap ruby
Diffstat (limited to 'community')
-rw-r--r--community/rubygems/PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/community/rubygems/PKGBUILD b/community/rubygems/PKGBUILD
index 8bf697ea..472071e2 100644
--- a/community/rubygems/PKGBUILD
+++ b/community/rubygems/PKGBUILD
@@ -1,18 +1,16 @@
-# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
-# and depend on 'ruby'
-# this means that 'ruby setup.py' is not found (must set PATH to bootstrap ruby)
-makedepends=(ruby-bootstrap)
-depends=()
-
-# install to final destination in /usr and not into /opt/ruby-xxx
+# bootstrapped packages in first step from /opt/ruby- contain
+# /opt/ruby-XXX/bin in the binaries in /usr/bin and they have
+# wrong architecture strings in native library code
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
+ '
+)"
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
- 3 i PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
- $ i sed -i "1s|.*|#\!/usr/bin/ruby|" "${pkgdir}"/usr/bin/gem
- $ i sed -i "1s|.*|#\!/usr/bin/ruby|" "${pkgdir}"/usr/bin/rbs
- $ i sed -i "1s|.*|#\!/usr/bin/ruby|" "${pkgdir}"/usr/bin/typeprof
+ 3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"