Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 18:40:30 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 18:40:30 +0200
commit8da98728a98fa4e6e0b777cc218d07fd72431ce3 (patch)
tree10984aaf831ead20770b3ca6b002a216c5e5de13 /community
parentfa90cfa31b9142839242e67060cc8533b489fba7 (diff)
community/ruby-rake: patching ruby in shell wrappers
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 67fe250e..a6209e1b 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,13 +1,16 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
/_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
+ $ i sed -i "1s|.*|#\!/usr/bin/ruby|" "${pkgdir}"/usr/bin/rake
'
)"