Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/ruby-rake/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 67fe250e..a6209e1b 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,13 +1,16 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ 3 i PATH="/opt/ruby-bootstrap-3.0.4/bin:${PATH}"
/_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
+ $ i sed -i "1s|.*|#\!/usr/bin/ruby|" "${pkgdir}"/usr/bin/rake
'
)"