Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 17:38:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 17:38:51 +0200
commit1a6749e037ae9c710f919872451a660c27682f16 (patch)
treedbc5e667255e5e8c6f653c6f789aa4a8032d390c /community
parent7f63a8aa97392e6f22c59fb866baa52e10da327c (diff)
community/ruby-rake-*: wrong patching
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD9
-rw-r--r--community/ruby-rake/PKGBUILD9
2 files changed, 18 insertions, 0 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index 6cae4819..be4040c4 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -4,3 +4,12 @@ makedepends=(ruby-bootstrap)
# no documentation during bootstrapping
makedepends=(${makedepends[@]//ruby-rdoc/})
+
+# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ '
+)"
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 2c0767fc..6fe83cd9 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,3 +1,12 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'rust'
makedepends=(ruby-bootstrap)
+
+# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ '
+)"