Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-rake-compiler/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-rake-compiler/PKGBUILD')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index 6cae4819..be4040c4 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -4,3 +4,12 @@ makedepends=(ruby-bootstrap)
# no documentation during bootstrapping
makedepends=(${makedepends[@]//ruby-rdoc/})
+
+# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ '
+)"