Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-rake/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-rake/PKGBUILD')
-rw-r--r--community/ruby-rake/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 2c0767fc..6fe83cd9 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,3 +1,12 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'rust'
makedepends=(ruby-bootstrap)
+
+# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ '
+)"