Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD20
-rw-r--r--extra/rust/config.toml.patch24
2 files changed, 20 insertions, 24 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index d1895de0..7066b7eb 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,12 +6,12 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-b2sums+=('27922f26ca7fadf6b35a9a94f988f7985c752149043424c62d9e5a908dd5779c73f775d04c3ef92a0daabf2f681e5e2ce6c1c173594613b91f6b1b79c7a8f16c')
+b2sums+=('b438042bad72f2952b135a46ca7353b0f333f58b7e5658e0f08fed75eba5095407aca479cbd6911fbaf2aa26482dce047293cf7114ace537b15acc8f10223551')
eval "$(
declare -f prepare | \
sed '
- $ i patch -p1 -i "$srcdir/config.toml.patch"
+ $ i patch -p0 -i "$srcdir/config.toml.patch"
'
)"
@@ -19,7 +19,7 @@ eval "$(
eval "$(
declare -f build | \
sed '
- s/-j "$(nproc)"/-j8/
+ s/-j "$(nproc)"/$(grep -o -- "-j *[0-9]*" <<< ${MAKEFLAGS:--j8})/
'
)"
@@ -27,7 +27,7 @@ if [ "${CARCH}" != 'pentium4' ]; then
eval "$(
declare -f prepare | \
sed '
- $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs"
+ $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/compiler/rustc_target/src/spec/targets/i686_unknown_linux_gnu.rs"
'
)"
fi
@@ -68,6 +68,7 @@ pkgname=(
)
)
makedepends=(${makedepends[@]//lib32-gcc-libs/})
+makedepends=(${makedepends[@]//lib32-glibc/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support (this is preferable to using rust-bin below, but
@@ -77,10 +78,9 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support
-makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust168-bin')
+#makedepends=(${makedepends[@]//rust/})
+#makedepends+=('rust176-bin')
+
+# Do not run out of memory linking LLVM
+options+=(!debug)
-# rust 1.63 is built against llvm13.0 anbd OpenSSL 1.1, so force that
-# in as a make dependency
-#makedepends+=('openssl-1.1')
-#makedepends+=('llvm14-libs')
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index d0a351bb..c002cff6 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,7 +1,6 @@
-diff -rauN a/config.toml b/config.toml
---- a/config.toml 2023-01-22 09:04:27.684167483 +0100
-+++ b/config.toml 2023-01-22 09:05:53.794297289 +0100
-@@ -6,11 +6,10 @@
+--- config.toml.orig 2024-05-06 00:02:38.463811257 +0000
++++ config.toml 2024-05-06 00:57:21.364799544 +0000
+@@ -6,9 +6,8 @@
[build]
target = [
@@ -10,21 +9,18 @@ diff -rauN a/config.toml b/config.toml
- "x86_64-unknown-linux-musl",
+ "i686-unknown-linux-musl",
"wasm32-unknown-unknown",
-- "wasm32-wasi",
-+ "wasm32-wasi"
+ "wasm32-wasi",
]
- cargo = "/usr/bin/cargo"
- rustc = "/usr/bin/rustc"
-@@ -28,7 +27,7 @@
- prefix = "/usr"
-
+@@ -39,7 +38,7 @@
[rust]
+ codegen-units-std = 1
+ debuginfo-level = 1
-debuginfo-level-std = 2
-+debuginfo-level-std = 0
++debuginfo-level-std = 1
channel = "stable"
- description = "Arch Linux rust 1:1.66.1-2"
+ description = "Arch Linux :-"
rpath = false
-@@ -61,7 +60,7 @@
+@@ -65,7 +64,7 @@
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"