Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index d1895de0..14ddf770 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-b2sums+=('27922f26ca7fadf6b35a9a94f988f7985c752149043424c62d9e5a908dd5779c73f775d04c3ef92a0daabf2f681e5e2ce6c1c173594613b91f6b1b79c7a8f16c')
+b2sums+=('916e62176ff8f943428532c28ec31632c153db5a9e906ae7a45df88cac72d437d23a56eb05e915ea2b2f524ac96d0b9ff8c106ed82572f7ed3324ded3fcf5a74')
eval "$(
declare -f prepare | \
@@ -19,7 +19,7 @@ eval "$(
eval "$(
declare -f build | \
sed '
- s/-j "$(nproc)"/-j8/
+ s/-j "$(nproc)"/$(grep -o -- "-j *[0-9]*" <<< ${MAKEFLAGS:--j8})/
'
)"
@@ -27,7 +27,7 @@ if [ "${CARCH}" != 'pentium4' ]; then
eval "$(
declare -f prepare | \
sed '
- $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs"
+ $ i sed -i "s/pentium4/pentium3/g" "$srcdir/rustc-$pkgver-src/compiler/rustc_target/src/spec/targets/i686_unknown_linux_gnu.rs"
'
)"
fi
@@ -78,9 +78,7 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support
makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust168-bin')
+makedepends+=('rust176-bin')
-# rust 1.63 is built against llvm13.0 anbd OpenSSL 1.1, so force that
-# in as a make dependency
-#makedepends+=('openssl-1.1')
-#makedepends+=('llvm14-libs')
+# Do not run out of memory linking LLVM
+options+=(!debug)