Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby/PKGBUILD')
-rw-r--r--community/ruby/PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/community/ruby/PKGBUILD b/community/ruby/PKGBUILD
index 005e96e9..530cd9f4 100644
--- a/community/ruby/PKGBUILD
+++ b/community/ruby/PKGBUILD
@@ -1,10 +1,20 @@
# patch architecture in helper shared libs
-eval "$(
- declare -f package_ruby | \
- sed '
- s|x86_64-linux|i686-linux|g
- '
-)"
+if [ "${CARCH}" = "pentium4" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f package_ruby | \
+ sed '
+ s|x86_64-linux|i686-linux|g
+ '
+ )"
+fi
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f package_ruby | \
+ sed '
+ s|x86_64-linux|i486-linux|g
+ '
+ )"
+fi
# disable testing on i486, hopefully this disables also clangd-fuzzer
if [ "${CARCH}" = "i486" ]; then