Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 09:55:24 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 09:55:24 +0200
commitd1e1ef47554501c6a1a13e45e2bef15887c98d59 (patch)
treea7e9d1090ea34c6806dc5b364879a92c641d0fa6 /community/ruby/PKGBUILD
parenteff6b643cf1bc54806f47d2eaef3f64a53f1fa23 (diff)
community/ruby: set arch on 486 to i486-linux
Diffstat (limited to 'community/ruby/PKGBUILD')
-rw-r--r--community/ruby/PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/community/ruby/PKGBUILD b/community/ruby/PKGBUILD
index 005e96e9..530cd9f4 100644
--- a/community/ruby/PKGBUILD
+++ b/community/ruby/PKGBUILD
@@ -1,10 +1,20 @@
# patch architecture in helper shared libs
-eval "$(
- declare -f package_ruby | \
- sed '
- s|x86_64-linux|i686-linux|g
- '
-)"
+if [ "${CARCH}" = "pentium4" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f package_ruby | \
+ sed '
+ s|x86_64-linux|i686-linux|g
+ '
+ )"
+fi
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f package_ruby | \
+ sed '
+ s|x86_64-linux|i486-linux|g
+ '
+ )"
+fi
# disable testing on i486, hopefully this disables also clangd-fuzzer
if [ "${CARCH}" = "i486" ]; then