Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-rake
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-rake')
-rw-r--r--community/ruby-rake/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 961dcd18..b440e9e6 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,12 +1,11 @@
-# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
-depends=(${depends[@]//ruby/})
-depends+='ruby-bootstrap'
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'rust'
+makedepends=(ruby-bootstrap)
-# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
'
)"
-