Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-rake
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 10:51:02 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-07 10:51:02 +0200
commitcb5d828d7401c0918e2af3250228b770870a6283 (patch)
treeab02e5174d70e6ebc066766536e3a58fe93e5cd5 /community/ruby-rake
parentd1e1ef47554501c6a1a13e45e2bef15887c98d59 (diff)
community/ruby-rake: rebuild for using ruby instead of ruby-bootstrap
Diffstat (limited to 'community/ruby-rake')
-rw-r--r--community/ruby-rake/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 961dcd18..b440e9e6 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,12 +1,11 @@
-# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
-depends=(${depends[@]//ruby/})
-depends+='ruby-bootstrap'
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'rust'
+makedepends=(ruby-bootstrap)
-# create /opt/ruby-xxx/bin
+# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
'
)"
-