Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/libarchive/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index 803046dd..56ede898 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -2,3 +2,11 @@
if [ "${CARCH}" = "i486" ]; then
sha256sums=(SKIP)
fi
+
+# ABI differences in libxml2, disable XAR
+eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --without-xml2 /
+ '
+)"