Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2025-03-16 16:57:56 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2025-03-16 16:57:56 +0100
commit8f131e0f231986a196bebd2bce7258ad0beddc18 (patch)
tree46213805bc637f68d7d9e58112a80ac54145c940
parent7345a8d434ad2f1c55b470b20d3efc05517ca474 (diff)
core/libarchive: build without libxml2 feature (but link against it)
-rw-r--r--core/libarchive/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index 803046dd..56ede898 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -2,3 +2,11 @@
if [ "${CARCH}" = "i486" ]; then
sha256sums=(SKIP)
fi
+
+# ABI differences in libxml2, disable XAR
+eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --without-xml2 /
+ '
+)"