Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-07-24 15:21:40 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-07-24 15:21:40 +0200
commitf15554b97de9be4baddbd44cf7aa81d68a60fc41 (patch)
tree6123affc24d95e840d62518372b743bdfe177fe6 /extra
parentb2daf56d5157f1a3d042b3ecb2f46debd7630704 (diff)
extra/tbb: ignoring some test errors in tests on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/tbb/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/tbb/PKGBUILD b/extra/tbb/PKGBUILD
index e7b88573..ea8c3d64 100644
--- a/extra/tbb/PKGBUILD
+++ b/extra/tbb/PKGBUILD
@@ -32,3 +32,13 @@ fi
if [ "$CARCH" == 'i486' ]; then
unset check
fi
+
+# ignore some errors in test
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /CXXFLAGS/ a export CXXFLAGS="$CXXFLAGS -Wno-error=array-bounds -Wno-error=use-after-free"
+ '
+ )"
+fi