Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-07-24 12:29:04 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-07-24 12:29:04 +0200
commitb2daf56d5157f1a3d042b3ecb2f46debd7630704 (patch)
tree10db65d33f4ed40173ceebd83f97eff71c14a182 /extra
parent4b55218e04177d35a006dda61730f6c8fe57d84b (diff)
extra/libinput: no debug-gui on i486, usues Gnome and half of broken libraries on i486
Diffstat (limited to 'extra')
-rw-r--r--extra/libinput/PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/extra/libinput/PKGBUILD b/extra/libinput/PKGBUILD
index 0bf3ff0b..7d2e83a9 100644
--- a/extra/libinput/PKGBUILD
+++ b/extra/libinput/PKGBUILD
@@ -1,5 +1,12 @@
+# used by debug gui
# fails to rebuild currently on i486
# /usr/bin/ld: warning: libicui18n.so.69, needed by /usr/lib//libtracker-sparql-3.0.
if [ "$CARCH" == 'i486' ]; then
- makedepends+=(icu69)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson /arch-meson -Ddebug-gui=false /g
+ '
+ )"
+ makedepends+=(icu69)
fi