Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-08-28 00:17:13 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-08-28 00:17:13 +0300
commit94b28e794a9b3a562851a248a889ba6b6ed849c8 (patch)
tree1a4a46cd870cc87f0e7cb512db53224d6d388b3f /extra
parent1223ce18ef181edc5b472a1da24818487ade4339 (diff)
extra/octave: Workaround for old jar
Diffstat (limited to 'extra')
-rw-r--r--extra/octave/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/octave/PKGBUILD b/extra/octave/PKGBUILD
index 406c2a07..fb396f1a 100644
--- a/extra/octave/PKGBUILD
+++ b/extra/octave/PKGBUILD
@@ -2,3 +2,12 @@
if [ "$CARCH" = 'i486' ]; then
depends=(${depends[@]//qscintilla-qt5/})
fi
+
+# At the time of writing, the upstream PGBUILD does the following at the end:
+# jar --extract --file="$pkgdir/usr/share/octave/$pkgver/m/java/octave.jar"
+# rm -rf "$pkgdir/usr/share/octave/$pkgver/m/java/octave.jar"
+# jar --create --date="$ARCHIVE_DATE" --file="$pkgdir/usr/share/octave/$pkgver/m/java/octave.jar" ./*
+#
+# Our jar currently is too old to support --date, so for now, don't run those.
+# And yes, I can't be bothered escaping the . in .jar
+eval "$(declare -f package | sed '/jar /d;/rm -rf.*octave.jar/d')"