Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/octave/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/octave/PKGBUILD')
-rw-r--r--extra/octave/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/octave/PKGBUILD b/extra/octave/PKGBUILD
index 406c2a07..fb396f1a 100644
--- a/extra/octave/PKGBUILD
+++ b/extra/octave/PKGBUILD
@@ -2,3 +2,12 @@
if [ "$CARCH" = 'i486' ]; then
depends=(${depends[@]//qscintilla-qt5/})
fi
+
+# At the time of writing, the upstream PGBUILD does the following at the end:
+# jar --extract --file="$pkgdir/usr/share/octave/$pkgver/m/java/octave.jar"
+# rm -rf "$pkgdir/usr/share/octave/$pkgver/m/java/octave.jar"
+# jar --create --date="$ARCHIVE_DATE" --file="$pkgdir/usr/share/octave/$pkgver/m/java/octave.jar" ./*
+#
+# Our jar currently is too old to support --date, so for now, don't run those.
+# And yes, I can't be bothered escaping the . in .jar
+eval "$(declare -f package | sed '/jar /d;/rm -rf.*octave.jar/d')"