Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-01-22 12:01:49 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-01-22 12:01:49 +0100
commit286f74a57b3d934a14433d687f8b7d074d63712b (patch)
treeb114e6aba380a53762258b385bd66d86d94d0aa2 /extra/rust
parent5ca6b0fd9f2e4a22cdfa459c601dcbd825161da7 (diff)
extra/rust: trying to bootstrap with rust165-bin
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD16
-rw-r--r--extra/rust/config.toml.patch16
2 files changed, 15 insertions, 17 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 98d746d3..ac1cb526 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('a8b42b5f47c0eaebafbb2cd1f39d2f944945cbb55e87d4dc21c7bd5b1b8964d8')
+sha256sums+=('d27cb75f657cbeac60b96a33450a0e5a7dd96c02271d9148219096353c6f30ac')
eval "$(
declare -f prepare | \
@@ -72,13 +72,15 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support (this is preferable to using rust-bin below, but
# requires all intermediate versions of rust to be built
-makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust162')
+#makedepends=(${makedepends[@]//rust/})
+#makedepends+=('rust162')
# Enable on demand, if your previous rust is broken use previous version
# from build-support
-#makedepends=(${makedepends[@]//rust/})
-#makedepends+=('rust159-bin')
+makedepends=(${makedepends[@]//rust/})
+makedepends+=('rust165-bin')
-# rust 1.61 is built against llvm13.0, so force that in as a make dependency
-#makedepends+=('llvm13-libs')
+# rust 1.63 is built against llvm13.0 anbd OpenSSL 1.1, so force that
+# in as a make dependency
+#makedepends+=('openssl-1.1')
+#makedepends+=('llvm14-libs')
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index e262d277..d0a351bb 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,6 +1,6 @@
diff -rauN a/config.toml b/config.toml
---- a/config.toml 2021-12-09 10:47:47.487749605 +0100
-+++ b/config.toml 2021-12-09 11:12:50.904278715 +0100
+--- a/config.toml 2023-01-22 09:04:27.684167483 +0100
++++ b/config.toml 2023-01-22 09:05:53.794297289 +0100
@@ -6,11 +6,10 @@
[build]
@@ -22,15 +22,11 @@ diff -rauN a/config.toml b/config.toml
-debuginfo-level-std = 2
+debuginfo-level-std = 0
channel = "stable"
- description = "Arch Linux $pkgbase $epoch:$pkgver-$pkgrel"
+ description = "Arch Linux rust 1:1.66.1-2"
rpath = false
-@@ -45,10 +44,10 @@
- [dist]
- compression-formats = ["gz"]
-
--[target.x86_64-unknown-linux-gnu]
-+[target.i686-unknown-linux-gnu]
- llvm-config = "/usr/bin/llvm-config"
+@@ -61,7 +60,7 @@
+ ar = "/usr/bin/gcc-ar"
+ ranlib = "/usr/bin/gcc-ranlib"
-[target.x86_64-unknown-linux-musl]
+[target.i686-unknown-linux-musl]