Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/rust/PKGBUILD')
-rw-r--r--extra/rust/PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 98d746d3..ac1cb526 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('a8b42b5f47c0eaebafbb2cd1f39d2f944945cbb55e87d4dc21c7bd5b1b8964d8')
+sha256sums+=('d27cb75f657cbeac60b96a33450a0e5a7dd96c02271d9148219096353c6f30ac')
eval "$(
declare -f prepare | \
@@ -72,13 +72,15 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support (this is preferable to using rust-bin below, but
# requires all intermediate versions of rust to be built
-makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust162')
+#makedepends=(${makedepends[@]//rust/})
+#makedepends+=('rust162')
# Enable on demand, if your previous rust is broken use previous version
# from build-support
-#makedepends=(${makedepends[@]//rust/})
-#makedepends+=('rust159-bin')
+makedepends=(${makedepends[@]//rust/})
+makedepends+=('rust165-bin')
-# rust 1.61 is built against llvm13.0, so force that in as a make dependency
-#makedepends+=('llvm13-libs')
+# rust 1.63 is built against llvm13.0 anbd OpenSSL 1.1, so force that
+# in as a make dependency
+#makedepends+=('openssl-1.1')
+#makedepends+=('llvm14-libs')