Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-setuptools
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-12-20 20:31:05 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-12-20 20:31:05 +0100
commit6e4887f11e1bd08fbf5a9204193b85718345a29a (patch)
tree064a7461622a1de136b700a410c02f4700cd3012 /extra/python-setuptools
parent51d532524aacc662bc46e2c24a68d038f8cb2d39 (diff)
extra/python-setuptools: applying ensurepip bootstrapping trick from upstream
Diffstat (limited to 'extra/python-setuptools')
-rw-r--r--extra/python-setuptools/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
index 2b768f5c..e0ca72d8 100644
--- a/extra/python-setuptools/PKGBUILD
+++ b/extra/python-setuptools/PKGBUILD
@@ -13,3 +13,12 @@ eval "$(
s/\(python.*\)/\1 || true/
'
)"
+
+# repeat bootstrap hack from upstream, enable pip
+eval "$(
+ declare -f prepare | \
+ sed '
+ /rm/ i \
+ python -m ensurepip
+ '
+)"