Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/mesa
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-06-16 16:44:27 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-06-16 16:44:27 +0200
commitc9edcbedf149ff3881523ee1475d8d4c7a7bb84c (patch)
tree3b22c92af10f1b439b31f57cf64975ce69ad3821 /extra/mesa
parent23db8c4956e6e903970d23891b1c0d6d2995ebdd (diff)
extra/mesa-amber: redone non-lto on i486
Diffstat (limited to 'extra/mesa')
-rw-r--r--extra/mesa/PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index 122512e9..b99acf24 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -8,7 +8,12 @@ if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
)"
fi
-# LTO on i486 results in out-of-memory
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi
if [ "$CARCH" == 'i486' ]; then
eval "$(
declare -f build | \