Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/mesa-amber/PKGBUILD7
-rw-r--r--extra/mesa/PKGBUILD7
2 files changed, 12 insertions, 2 deletions
diff --git a/extra/mesa-amber/PKGBUILD b/extra/mesa-amber/PKGBUILD
index 9f521908..3d1b434b 100644
--- a/extra/mesa-amber/PKGBUILD
+++ b/extra/mesa-amber/PKGBUILD
@@ -8,7 +8,12 @@ if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
)"
fi
-# LTO on i486 results in out-of-memory
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi
if [ "$CARCH" == 'i486' ]; then
eval "$(
declare -f build | \
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index 122512e9..b99acf24 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -8,7 +8,12 @@ if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
)"
fi
-# LTO on i486 results in out-of-memory
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi
if [ "$CARCH" == 'i486' ]; then
eval "$(
declare -f build | \