Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libfido2/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-10 00:33:26 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-10 00:33:26 +0200
commit7b9bd29c66fb4374a566e315abc4394e5b624c41 (patch)
treeffdd23b4516a094e47b594d71348d31b9ccbc3d6 /extra/libfido2/PKGBUILD
parent43160a5cc3c537c86a28dbc9dbfd9345a22ed064 (diff)
extra/libfido: It needs to be in extra, not core
Diffstat (limited to 'extra/libfido2/PKGBUILD')
-rw-r--r--extra/libfido2/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/extra/libfido2/PKGBUILD b/extra/libfido2/PKGBUILD
new file mode 100644
index 00000000..3e4475a6
--- /dev/null
+++ b/extra/libfido2/PKGBUILD
@@ -0,0 +1,28 @@
+# break cycles with systemd
+depends=(${depends[@]//systemd-libs/})
+makedepends=(${makedepends[@]//systemd/})
+
+# somehow -Wno-dev disappeard and we have full -Werror again
+source+=(libfido2-1.14.0-no-werror.patch)
+sha512sums+=(3bc56d2926d5cfc8838d23775254e0d01f68c79a95b94f6787e72b8402c4617cc2a4abf75be6c573e619fd6f94574bdeb2b79f162354230372e935f6e20da709)
+b2sums+=(8a50d473ca2eda54ceaeaae0ce85af1109119949ac5db354b02b726507547f4a9c1f38f9e7d5c598b328ccf3276224a0e5374222dafeaf76e7ebc9aeb891d801)
+
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${pkgbase}-${pkgver}" \
+ patch -Np1 -i "$srcdir/libfido2-1.14.0-no-werror.patch"
+ '
+)"
+
+# manpage generators are most likely broken
+eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DBUILD_MANPAGES=OFF /
+ '
+)"