Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/libfido2
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-03-10 00:33:26 +0200
committerTasos Sahanidis <tasos@tasossah.com>2024-03-10 00:33:26 +0200
commit7b9bd29c66fb4374a566e315abc4394e5b624c41 (patch)
treeffdd23b4516a094e47b594d71348d31b9ccbc3d6 /extra/libfido2
parent43160a5cc3c537c86a28dbc9dbfd9345a22ed064 (diff)
extra/libfido: It needs to be in extra, not core
Diffstat (limited to 'extra/libfido2')
-rw-r--r--extra/libfido2/PKGBUILD28
-rw-r--r--extra/libfido2/libfido2-1.14.0-no-werror.patch38
2 files changed, 66 insertions, 0 deletions
diff --git a/extra/libfido2/PKGBUILD b/extra/libfido2/PKGBUILD
new file mode 100644
index 00000000..3e4475a6
--- /dev/null
+++ b/extra/libfido2/PKGBUILD
@@ -0,0 +1,28 @@
+# break cycles with systemd
+depends=(${depends[@]//systemd-libs/})
+makedepends=(${makedepends[@]//systemd/})
+
+# somehow -Wno-dev disappeard and we have full -Werror again
+source+=(libfido2-1.14.0-no-werror.patch)
+sha512sums+=(3bc56d2926d5cfc8838d23775254e0d01f68c79a95b94f6787e72b8402c4617cc2a4abf75be6c573e619fd6f94574bdeb2b79f162354230372e935f6e20da709)
+b2sums+=(8a50d473ca2eda54ceaeaae0ce85af1109119949ac5db354b02b726507547f4a9c1f38f9e7d5c598b328ccf3276224a0e5374222dafeaf76e7ebc9aeb891d801)
+
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i cd "${srcdir}/${pkgbase}-${pkgver}" \
+ patch -Np1 -i "$srcdir/libfido2-1.14.0-no-werror.patch"
+ '
+)"
+
+# manpage generators are most likely broken
+eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DBUILD_MANPAGES=OFF /
+ '
+)"
diff --git a/extra/libfido2/libfido2-1.14.0-no-werror.patch b/extra/libfido2/libfido2-1.14.0-no-werror.patch
new file mode 100644
index 00000000..f8bc6f9d
--- /dev/null
+++ b/extra/libfido2/libfido2-1.14.0-no-werror.patch
@@ -0,0 +1,38 @@
+diff -rauN libfido2-1.14.0/CMakeLists.txt libfido2-1.14.0-no-werror/CMakeLists.txt
+--- libfido2-1.14.0/CMakeLists.txt 2023-11-13 08:19:20.000000000 +0100
++++ libfido2-1.14.0-no-werror/CMakeLists.txt 2024-03-09 15:26:30.835589345 +0100
+@@ -90,7 +90,7 @@
+ endif()
+
+ check_c_compiler_flag("-Wshorten-64-to-32" HAVE_SHORTEN_64_TO_32)
+-check_c_compiler_flag("-Werror -fstack-protector-all" HAVE_STACK_PROTECTOR_ALL)
++check_c_compiler_flag("-fstack-protector-all" HAVE_STACK_PROTECTOR_ALL)
+
+ check_include_files(cbor.h HAVE_CBOR_H)
+ check_include_files(endian.h HAVE_ENDIAN_H)
+@@ -123,7 +123,7 @@
+ try_compile(HAVE_POSIX_IOCTL
+ "${CMAKE_CURRENT_BINARY_DIR}/posix_ioctl_check.o"
+ "${CMAKE_CURRENT_SOURCE_DIR}/openbsd-compat/posix_ioctl_check.c"
+- COMPILE_DEFINITIONS "-Werror -Woverflow -Wsign-conversion")
++ COMPILE_DEFINITIONS "-Woverflow -Wsign-conversion")
+
+ list(APPEND CHECK_VARIABLES
+ HAVE_ARC4RANDOM_BUF
+@@ -295,7 +295,6 @@
+
+ add_compile_options(-Wall)
+ add_compile_options(-Wextra)
+- add_compile_options(-Werror)
+ add_compile_options(-Wshadow)
+ add_compile_options(-Wcast-qual)
+ add_compile_options(-Wwrite-strings)
+@@ -322,7 +321,7 @@
+
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -g2")
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -fno-omit-frame-pointer")
+- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -D_FORTIFY_SOURCE=2")
++ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
+
+ if(CRYPTO_VERSION VERSION_GREATER_EQUAL 3.0)
+ add_definitions(-DOPENSSL_API_COMPAT=0x10100000L)