Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-02-27 16:27:36 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-02-27 16:27:36 +0100
commit7fb0b8b8192a5901b675c24ce5d363cc8c73befb (patch)
tree5f1cb52fa5d11b5527d0a1b1b98ce0967efadf07 /core
parent4d7c9276d76afa9f58d15ef3ff783b55eb9deb3e (diff)
core/brotli: patch CARCH for python tests
Diffstat (limited to 'core')
-rw-r--r--core/brotli/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/core/brotli/PKGBUILD b/core/brotli/PKGBUILD
new file mode 100644
index 00000000..a2e290e0
--- /dev/null
+++ b/core/brotli/PKGBUILD
@@ -0,0 +1,9 @@
+if [ ! "${CARCH}" = "i686" ]; then
+ # patch architecture where needed
+ eval "$(
+ declare -f check | \
+ sed '
+ /PYTHONPATH=.*/s/$CARCH/i686/
+ '
+ )"
+fi