Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/glibc
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-08-04 14:26:31 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-08-04 14:26:31 +0200
commit9338676972ce8a20454601e5f4a944090f676443 (patch)
treeb089560ed4f2ffb40b4e488f7fdc0f6414e1a779 /core/glibc
parentec93e7380a4d024ec38fe80bcbcb505ddc6d055f (diff)
core/glibc: ignored some more tests
Diffstat (limited to 'core/glibc')
-rw-r--r--core/glibc/PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index 12ddad27..e5cf18d7 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -78,15 +78,13 @@ eval "$(
# upstream test skipping breaks Makefiles in test, also glibc 2.25 currently fails
# in the following tests:
# FAIL: elf/tst-audit-tlsdesc
-#FAIL: elf/tst-audit-tlsdesc-dlopen
-#FAIL: elf/tst-gnu2-tls1
-#FAIL: math/test-float-clog10
-#FAIL: math/test-float32-clog10
-#FAIL: misc/tst-bz21269
-#FAIL: misc/tst-ntp_gettime
-#FAIL: misc/tst-ntp_gettimex
-#FAIL: time/tst-adjtime
-#FAIL: time/tst-clock2
+# FAIL: elf/tst-audit-tlsdesc-dlopen
+# FAIL: elf/tst-gnu2-tls1
+# FAIL: misc/tst-bz21269
+# FAIL: misc/tst-ntp_gettime
+# FAIL: misc/tst-ntp_gettimex
+# FAIL: time/tst-adjtime
+# FAIL: time/tst-clock2
# the last once are exactly the once we had to patch, so we ignore this.
eval "$(
declare -f check | \
@@ -95,6 +93,11 @@ eval "$(
s/skip_test tst-ntp_gettime/skip_test tst-ntp_gettime-time64/
s/skip_test tst-adjtime/skip_test tst-adjtime-time64/
s/skip_test tst-clock2/skip_test tst-clock2-time64/
+ /make -O check/ i \
+ skip_test tst-audit-tlsdesc elf/Makefile \
+ skip_test tst-audit-tlsdesc-dlopen elf/Makefile \
+ skip_test tst-gnu2-tls1 elf/Makefile \
+ skip_test tst-bz21269 misc/Makefile
s/make -O check/make -O check || true/
'
)"
@@ -124,5 +127,5 @@ eval "$(
'
)"
-# ignoring tests for now
+# ignoring tests for now (they hang, checked manually, see skip_tests above)
unset check