Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/glibc
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-08-04 12:41:23 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-08-04 12:41:23 +0200
commitec93e7380a4d024ec38fe80bcbcb505ddc6d055f (patch)
treebec59346233d38fa9e60088de250bb5d3cdba14e /core/glibc
parent5935589ef556f1dd64ae5dfe0daa0279ff6cf4de (diff)
core/glibc: rebuilding with locale generation
Diffstat (limited to 'core/glibc')
-rw-r--r--core/glibc/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index bae7a05f..12ddad27 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -1,6 +1,7 @@
# remove lib32-* stuff
pkgname=(${pkgname[@]/lib32-*/})
+makedepends=(${makedepends[@]/lib32-*/})
unset -f 'package_lib32-glibc'
eval "$(
@@ -115,5 +116,13 @@ eval "$(
'
)"
+# readd locale generation removed by lib32 sed-fu above in build!
+eval "$(
+ declare -f build | \
+ sed '
+ $ i locale/localedef -c -f ../glibc/localedata/charmaps/UTF-8 -i ../glibc/localedata/locales/C ../C.UTF-8/
+ '
+)"
+
# ignoring tests for now
unset check