Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 08:30:28 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 08:30:28 +0200
commit969bd2f61e0bfbe3b5666b13f9d8923f7846fd62 (patch)
tree736e453bd680280676cdcbe8f35e5d6e35e46441 /community
parent6182e7af4cde97cbf8a0f242a29382c7055f7c63 (diff)
community/ruby-rake*: another try on /opt
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD10
-rw-r--r--community/ruby-rake/PKGBUILD9
2 files changed, 13 insertions, 6 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index 019e82a9..e76fc93c 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,11 +1,13 @@
-# no documentation during bootstrapping
-makedepends=(${makedepends[@]//ruby-rdoc/})
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends+=(ruby-bootstrap)
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
- /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
+ s|local _gemdir.*|local _gemdir="/opt/${pkgname}-${pkgver}/lib/ruby/gems/3.0.0"|g
+ /local _gemdir/ a mkdir -p "${pkgdir}"/opt/${pkgname}-${pkgver}/bin
+ /local _gemdir/ a mkdir -p "${pkgdir}"/usr/bin
'
)"
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 013d5c83..e76fc93c 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,8 +1,13 @@
+# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
+# and depend on 'ruby'
+makedepends+=(ruby-bootstrap)
+
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
- /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
+ s|local _gemdir.*|local _gemdir="/opt/${pkgname}-${pkgver}/lib/ruby/gems/3.0.0"|g
+ /local _gemdir/ a mkdir -p "${pkgdir}"/opt/${pkgname}-${pkgver}/bin
+ /local _gemdir/ a mkdir -p "${pkgdir}"/usr/bin
'
)"