Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-12-17 14:29:59 +0100
committerErich Eckner <git@eckner.net>2019-12-17 14:29:59 +0100
commit8ad3c5752807834458a67717acfdc5ce6976018b (patch)
treeb861662aa8d27aabd50e910698d392a4137ee464 /community
parent540dd08265bc5db4d071333d54683298aa7f91da (diff)
community/blender: reintroduced
Diffstat (limited to 'community')
-rw-r--r--community/blender/PKGBUILD17
-rw-r--r--community/blender/arm-no-sse2.patch15
2 files changed, 32 insertions, 0 deletions
diff --git a/community/blender/PKGBUILD b/community/blender/PKGBUILD
index a10de18b..4a583535 100644
--- a/community/blender/PKGBUILD
+++ b/community/blender/PKGBUILD
@@ -1,3 +1,20 @@
makedepends=(
${makedepends[@]/cuda/}
)
+pkgdesc+=", without nonfree CUDA support"
+eval "$(
+ declare -f build \
+ | sed '
+ /^cmake / s/$/ -DWITH_CYCLES_CUDA_BINARIES=OFF -DWITH_CYCLES_DEVICE_CUDA=OFF
+ '
+)"
+source_i686+=('arm-no-sse2.patch')
+sha512sum_i686+=('13890f9cd11ca20bcb6f12206c990e25c0d08699feab0fca37607d847d2aebd2d2f423023986e120eaaeb0beca9a440a4d42007dcac2054fe6cdaf745de43402')
+if [ "${CARCH}" = 'i686' ]; then
+ eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -Np1 -i "$srcdir"/arm-no-sse2.patch
+ '
+ )"
+fi
diff --git a/community/blender/arm-no-sse2.patch b/community/blender/arm-no-sse2.patch
new file mode 100644
index 00000000..722c70e9
--- /dev/null
+++ b/community/blender/arm-no-sse2.patch
@@ -0,0 +1,15 @@
+diff --git a/intern/cycles/bvh/bvh_embree.cpp b/intern/cycles/bvh/bvh_embree.cpp
+index d12a0c1..1df2de3 100644
+--- a/intern/cycles/bvh/bvh_embree.cpp
++++ b/intern/cycles/bvh/bvh_embree.cpp
+@@ -299,8 +299,10 @@ BVHEmbree::BVHEmbree(const BVHParams &params_,
+ use_ribbons(params.curve_flags & CURVE_KN_RIBBONS),
+ dynamic_scene(true)
+ {
++#if defined(__x86_64__) || defined(_M_X64)
+ _MM_SET_FLUSH_ZERO_MODE(_MM_FLUSH_ZERO_ON);
+ _MM_SET_DENORMALS_ZERO_MODE(_MM_DENORMALS_ZERO_ON);
++#endif
+ thread_scoped_lock lock(rtc_shared_mutex);
+ if (rtc_shared_users == 0) {
+ rtc_shared_device = rtcNewDevice("verbose=0");