Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/blender/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/blender/PKGBUILD')
-rw-r--r--community/blender/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/community/blender/PKGBUILD b/community/blender/PKGBUILD
index a10de18b..4a583535 100644
--- a/community/blender/PKGBUILD
+++ b/community/blender/PKGBUILD
@@ -1,3 +1,20 @@
makedepends=(
${makedepends[@]/cuda/}
)
+pkgdesc+=", without nonfree CUDA support"
+eval "$(
+ declare -f build \
+ | sed '
+ /^cmake / s/$/ -DWITH_CYCLES_CUDA_BINARIES=OFF -DWITH_CYCLES_DEVICE_CUDA=OFF
+ '
+)"
+source_i686+=('arm-no-sse2.patch')
+sha512sum_i686+=('13890f9cd11ca20bcb6f12206c990e25c0d08699feab0fca37607d847d2aebd2d2f423023986e120eaaeb0beca9a440a4d42007dcac2054fe6cdaf745de43402')
+if [ "${CARCH}" = 'i686' ]; then
+ eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -Np1 -i "$srcdir"/arm-no-sse2.patch
+ '
+ )"
+fi