Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-10 20:08:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-10 20:08:07 +0200
commit57fa358891b0a42208b32281ec67bd832fb33c98 (patch)
treea57eb686a71a0fd6f8ac603121634a4054513302 /community
parent97e0f612110ddeedcfc7d79254e034333b1bc2fa (diff)
community/ruby: reenabled ruby and patched for installing in proper native libary paths
Diffstat (limited to 'community')
-rw-r--r--community/ruby-abbrev/PKGBUILD2
-rw-r--r--community/ruby-base64/PKGBUILD2
-rw-r--r--community/ruby-benchmark/PKGBUILD2
-rw-r--r--community/ruby-bigdecimal/PKGBUILD9
-rw-r--r--community/ruby-bundler/PKGBUILD2
-rw-r--r--community/ruby-cgi/PKGBUILD9
-rw-r--r--community/ruby-csv/PKGBUILD2
-rw-r--r--community/ruby-date/PKGBUILD9
-rw-r--r--community/ruby-delegate/PKGBUILD2
-rw-r--r--community/ruby-did_you_mean/PKGBUILD2
-rw-r--r--community/ruby-digest/PKGBUILD11
-rw-r--r--community/ruby-drb/PKGBUILD2
-rw-r--r--community/ruby-english/PKGBUILD2
-rw-r--r--community/ruby-erb/PKGBUILD2
-rw-r--r--community/ruby-etc/PKGBUILD9
-rw-r--r--community/ruby-fcntl/PKGBUILD9
-rw-r--r--community/ruby-fiddle/PKGBUILD9
-rw-r--r--community/ruby-fileutils/PKGBUILD2
-rw-r--r--community/ruby-find/PKGBUILD2
-rw-r--r--community/ruby-forwardable/PKGBUILD2
-rw-r--r--community/ruby-getoptlong/PKGBUILD2
-rw-r--r--community/ruby-io-console/PKGBUILD9
-rw-r--r--community/ruby-io-nonblock/PKGBUILD9
-rw-r--r--community/ruby-io-wait/PKGBUILD9
-rw-r--r--community/ruby-ipaddr/PKGBUILD2
-rw-r--r--community/ruby-irb/PKGBUILD2
-rw-r--r--community/ruby-json/PKGBUILD9
-rw-r--r--community/ruby-logger/PKGBUILD2
-rw-r--r--community/ruby-minitest/PKGBUILD2
-rw-r--r--community/ruby-mutex_m/PKGBUILD2
-rw-r--r--community/ruby-net-http/PKGBUILD2
-rw-r--r--community/ruby-open-uri/PKGBUILD2
-rw-r--r--community/ruby-psych/PKGBUILD9
-rw-r--r--community/ruby-racc/PKGBUILD9
-rw-r--r--community/ruby-rake-compiler/PKGBUILD2
-rw-r--r--community/ruby-rake/PKGBUILD2
-rw-r--r--community/ruby-rdoc/PKGBUILD2
-rw-r--r--community/ruby-reline/PKGBUILD2
-rw-r--r--community/ruby-stringio/PKGBUILD9
-rw-r--r--community/ruby-test-unit/PKGBUILD2
-rw-r--r--community/ruby-time/PKGBUILD2
-rw-r--r--community/ruby-tmpdir/PKGBUILD2
-rw-r--r--community/ruby-uri/PKGBUILD2
43 files changed, 112 insertions, 74 deletions
diff --git a/community/ruby-abbrev/PKGBUILD b/community/ruby-abbrev/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-abbrev/PKGBUILD
+++ b/community/ruby-abbrev/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-base64/PKGBUILD b/community/ruby-base64/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-base64/PKGBUILD
+++ b/community/ruby-base64/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-benchmark/PKGBUILD b/community/ruby-benchmark/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-benchmark/PKGBUILD
+++ b/community/ruby-benchmark/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-bigdecimal/PKGBUILD b/community/ruby-bigdecimal/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-bigdecimal/PKGBUILD
+++ b/community/ruby-bigdecimal/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-bundler/PKGBUILD b/community/ruby-bundler/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-bundler/PKGBUILD
+++ b/community/ruby-bundler/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-cgi/PKGBUILD b/community/ruby-cgi/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-cgi/PKGBUILD
+++ b/community/ruby-cgi/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-csv/PKGBUILD b/community/ruby-csv/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-csv/PKGBUILD
+++ b/community/ruby-csv/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-date/PKGBUILD b/community/ruby-date/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-date/PKGBUILD
+++ b/community/ruby-date/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-delegate/PKGBUILD b/community/ruby-delegate/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-delegate/PKGBUILD
+++ b/community/ruby-delegate/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-did_you_mean/PKGBUILD b/community/ruby-did_you_mean/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-did_you_mean/PKGBUILD
+++ b/community/ruby-did_you_mean/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-digest/PKGBUILD b/community/ruby-digest/PKGBUILD
index 6285a5a7..40c4a4e2 100644
--- a/community/ruby-digest/PKGBUILD
+++ b/community/ruby-digest/PKGBUILD
@@ -14,6 +14,11 @@ eval "$(
'
)"
-# break test circle of dependencies on ourselves.. ;-)
-checkdepends=(${checkdepends[@]//ruby-digest/})
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-drb/PKGBUILD b/community/ruby-drb/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-drb/PKGBUILD
+++ b/community/ruby-drb/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-english/PKGBUILD b/community/ruby-english/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-english/PKGBUILD
+++ b/community/ruby-english/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-erb/PKGBUILD b/community/ruby-erb/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-erb/PKGBUILD
+++ b/community/ruby-erb/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-etc/PKGBUILD b/community/ruby-etc/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-etc/PKGBUILD
+++ b/community/ruby-etc/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-fcntl/PKGBUILD b/community/ruby-fcntl/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-fcntl/PKGBUILD
+++ b/community/ruby-fcntl/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-fiddle/PKGBUILD b/community/ruby-fiddle/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-fiddle/PKGBUILD
+++ b/community/ruby-fiddle/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-fileutils/PKGBUILD b/community/ruby-fileutils/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-fileutils/PKGBUILD
+++ b/community/ruby-fileutils/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-find/PKGBUILD b/community/ruby-find/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-find/PKGBUILD
+++ b/community/ruby-find/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-forwardable/PKGBUILD b/community/ruby-forwardable/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-forwardable/PKGBUILD
+++ b/community/ruby-forwardable/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-getoptlong/PKGBUILD b/community/ruby-getoptlong/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-getoptlong/PKGBUILD
+++ b/community/ruby-getoptlong/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-io-console/PKGBUILD b/community/ruby-io-console/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-io-console/PKGBUILD
+++ b/community/ruby-io-console/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-io-nonblock/PKGBUILD b/community/ruby-io-nonblock/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-io-nonblock/PKGBUILD
+++ b/community/ruby-io-nonblock/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-io-wait/PKGBUILD b/community/ruby-io-wait/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-io-wait/PKGBUILD
+++ b/community/ruby-io-wait/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-ipaddr/PKGBUILD b/community/ruby-ipaddr/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-ipaddr/PKGBUILD
+++ b/community/ruby-ipaddr/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-irb/PKGBUILD b/community/ruby-irb/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-irb/PKGBUILD
+++ b/community/ruby-irb/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-json/PKGBUILD b/community/ruby-json/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-json/PKGBUILD
+++ b/community/ruby-json/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-logger/PKGBUILD b/community/ruby-logger/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-logger/PKGBUILD
+++ b/community/ruby-logger/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-minitest/PKGBUILD b/community/ruby-minitest/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-minitest/PKGBUILD
+++ b/community/ruby-minitest/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-mutex_m/PKGBUILD b/community/ruby-mutex_m/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-mutex_m/PKGBUILD
+++ b/community/ruby-mutex_m/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-net-http/PKGBUILD b/community/ruby-net-http/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-net-http/PKGBUILD
+++ b/community/ruby-net-http/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-open-uri/PKGBUILD b/community/ruby-open-uri/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-open-uri/PKGBUILD
+++ b/community/ruby-open-uri/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-psych/PKGBUILD b/community/ruby-psych/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-psych/PKGBUILD
+++ b/community/ruby-psych/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-racc/PKGBUILD b/community/ruby-racc/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-racc/PKGBUILD
+++ b/community/ruby-racc/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-rdoc/PKGBUILD b/community/ruby-rdoc/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-rdoc/PKGBUILD
+++ b/community/ruby-rdoc/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-reline/PKGBUILD b/community/ruby-reline/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-reline/PKGBUILD
+++ b/community/ruby-reline/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-stringio/PKGBUILD b/community/ruby-stringio/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-stringio/PKGBUILD
+++ b/community/ruby-stringio/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"
diff --git a/community/ruby-test-unit/PKGBUILD b/community/ruby-test-unit/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-test-unit/PKGBUILD
+++ b/community/ruby-test-unit/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-time/PKGBUILD b/community/ruby-time/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-time/PKGBUILD
+++ b/community/ruby-time/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-tmpdir/PKGBUILD b/community/ruby-tmpdir/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-tmpdir/PKGBUILD
+++ b/community/ruby-tmpdir/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check
diff --git a/community/ruby-uri/PKGBUILD b/community/ruby-uri/PKGBUILD
index 472071e2..99c8af6b 100644
--- a/community/ruby-uri/PKGBUILD
+++ b/community/ruby-uri/PKGBUILD
@@ -13,5 +13,3 @@ eval "$(
3 i export RUBYLIB=/usr/lib/ruby/3.0.0/x86-linux
'
)"
-
-unset check