Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-cgi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-cgi/PKGBUILD')
-rw-r--r--community/ruby-cgi/PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/ruby-cgi/PKGBUILD b/community/ruby-cgi/PKGBUILD
index 472071e2..40c4a4e2 100644
--- a/community/ruby-cgi/PKGBUILD
+++ b/community/ruby-cgi/PKGBUILD
@@ -14,4 +14,11 @@ eval "$(
'
)"
-unset check
+# move native code to proper place (where ruby expects it)
+eval "$(
+ declare -f package | \
+ sed '
+ /local _gemdir.*/ a local _install_platform="$(ruby --disable-all -e '"'"'puts RUBY_PLATFORM'"'"')"
+ s|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_platform}|${pkgdir}/usr/lib/ruby/${_extension_api_version}/${_install_platform}|g
+ '
+)"