Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 10:59:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 10:59:21 +0200
commit577a9d43060275d3ca34e011db63e2ee178358bf (patch)
treedbc91c52e158f0e386101d147cbdf770774c1882 /community
parent27dfa710ef60c55d6003a9c600b9f84131078f9f (diff)
community/ruby-rake*: another try to for pathes back to /usr
Diffstat (limited to 'community')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD6
-rw-r--r--community/ruby-rake/PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index c54c38db..80f7a4ab 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,13 +1,13 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/opt/ruby-bootstrap-3.0.4/lib/ruby/gems/3.0.0"|g
- /local _gemdir/ a mkdir -p "${pkgdir}"/opt/ruby-bootstrap-3.0.4/bin
- /local _gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"
diff --git a/community/ruby-rake/PKGBUILD b/community/ruby-rake/PKGBUILD
index c54c38db..80f7a4ab 100644
--- a/community/ruby-rake/PKGBUILD
+++ b/community/ruby-rake/PKGBUILD
@@ -1,13 +1,13 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/opt/ruby-bootstrap-3.0.4/lib/ruby/gems/3.0.0"|g
- /local _gemdir/ a mkdir -p "${pkgdir}"/opt/ruby-bootstrap-3.0.4/bin
- /local _gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"