Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/ruby-rake-compiler/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-rake-compiler/PKGBUILD')
-rw-r--r--community/ruby-rake-compiler/PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/ruby-rake-compiler/PKGBUILD b/community/ruby-rake-compiler/PKGBUILD
index c54c38db..80f7a4ab 100644
--- a/community/ruby-rake-compiler/PKGBUILD
+++ b/community/ruby-rake-compiler/PKGBUILD
@@ -1,13 +1,13 @@
# building with ruby-bootstrap in /opt/ruby-xxx, but install into /usr
# and depend on 'ruby'
makedepends+=(ruby-bootstrap)
+depends=()
# install to final destination in /usr and not into /opt/ruby-xxx
eval "$(
declare -f package | \
sed '
- s|local _gemdir.*|local _gemdir="/opt/ruby-bootstrap-3.0.4/lib/ruby/gems/3.0.0"|g
- /local _gemdir/ a mkdir -p "${pkgdir}"/opt/ruby-bootstrap-3.0.4/bin
- /local _gemdir/ a mkdir -p "${pkgdir}"/usr/bin
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ /_gemdir/ a mkdir -p "${pkgdir}"/usr/bin/
'
)"