Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 20:13:27 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 20:13:27 +0200
commit1af08771d8bfca98d4d6238aeceaeed29a017dc0 (patch)
tree90106f7d3cf60666aa58e19a26bee981a639c95e /community
parent068f37d907e0956e6bd5bd6f024eff095b98a99c (diff)
community/ruby-$i: bootstrapping
Diffstat (limited to 'community')
-rw-r--r--community/ruby-open-uri/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/ruby-open-uri/PKGBUILD b/community/ruby-open-uri/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-open-uri/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+