Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 20:13:27 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-06 20:13:27 +0200
commit068f37d907e0956e6bd5bd6f024eff095b98a99c (patch)
treecf9948f79beb6f8abcf97fc43fac9e1d7cf478d9 /community
parent07e76c48d533e1f6dd3168f911cce28c71c3e6f9 (diff)
community/ruby-$i: bootstrapping
Diffstat (limited to 'community')
-rw-r--r--community/ruby-net-http/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/ruby-net-http/PKGBUILD b/community/ruby-net-http/PKGBUILD
new file mode 100644
index 00000000..f41379db
--- /dev/null
+++ b/community/ruby-net-http/PKGBUILD
@@ -0,0 +1,12 @@
+# bootstrapping with ruby-bootstrap in /opt/ruby-xxx
+depends=(${depends[@]//ruby/})
+depends+='ruby-bootstrap'
+
+# install to final destination in /usr and not into /opt/ruby-xxx
+eval "$(
+ declare -f package | \
+ sed '
+ s|local _gemdir.*|local _gemdir="/usr/lib/ruby/gems/3.0.0"|g
+ '
+)"
+