Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/go/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-04-04 17:50:54 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-04-04 17:50:54 +0200
commitcf7f85f496d56e7f80b296462934918c5b79629a (patch)
treefa28a7d35f5c9eb13a6a8e09f3e6aea8cdfc735b /community/go/PKGBUILD
parent434f133a7d80850ad2fb2ae81268a14e97519ce9 (diff)
community/go: added a x87 patch
Diffstat (limited to 'community/go/PKGBUILD')
-rw-r--r--community/go/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/go/PKGBUILD b/community/go/PKGBUILD
index 4fa88c30..e11f0cf1 100644
--- a/community/go/PKGBUILD
+++ b/community/go/PKGBUILD
@@ -30,3 +30,16 @@ if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# https://go-review.googlesource.com/c/go/+/257963
+source+=('go-x87.patch')
+sha256sums+=('8b124eaa7521bd0e3760b514829b1ecce3d3cd169f99c3629ff50b7769303802')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd "$pkgname" \n}\n'
+ } \
+ | sed '
+ $i patch -Np1 -i ../go-x87.patch
+ '
+)"