Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/go
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-04-04 17:50:54 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-04-04 17:50:54 +0200
commitcf7f85f496d56e7f80b296462934918c5b79629a (patch)
treefa28a7d35f5c9eb13a6a8e09f3e6aea8cdfc735b /community/go
parent434f133a7d80850ad2fb2ae81268a14e97519ce9 (diff)
community/go: added a x87 patch
Diffstat (limited to 'community/go')
-rw-r--r--community/go/PKGBUILD13
-rw-r--r--community/go/go-x87.patch28
2 files changed, 41 insertions, 0 deletions
diff --git a/community/go/PKGBUILD b/community/go/PKGBUILD
index 4fa88c30..e11f0cf1 100644
--- a/community/go/PKGBUILD
+++ b/community/go/PKGBUILD
@@ -30,3 +30,16 @@ if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# https://go-review.googlesource.com/c/go/+/257963
+source+=('go-x87.patch')
+sha256sums+=('8b124eaa7521bd0e3760b514829b1ecce3d3cd169f99c3629ff50b7769303802')
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() { cd "$pkgname" \n}\n'
+ } \
+ | sed '
+ $i patch -Np1 -i ../go-x87.patch
+ '
+)"
diff --git a/community/go/go-x87.patch b/community/go/go-x87.patch
new file mode 100644
index 00000000..0c0a584b
--- /dev/null
+++ b/community/go/go-x87.patch
@@ -0,0 +1,28 @@
+diff -rauN go/src/buildall.bash go-x87-patch/src/buildall.bash
+--- go/src/buildall.bash 2023-04-04 17:38:07.330008547 +0200
++++ go-x87-patch/src/buildall.bash 2023-04-04 17:39:07.929938685 +0200
+@@ -37,6 +37,7 @@
+
+ gettargets() {
+ ../bin/go tool dist list | sed -e 's|/|-|'
++ echo linux-386-387
+ echo linux-arm-arm5
+ }
+
+@@ -63,11 +64,15 @@
+ echo "### Building $target"
+ export GOOS=$(echo $target | sed 's/-.*//')
+ export GOARCH=$(echo $target | sed 's/.*-//')
+- unset GOARM
++ unset GO386 GOARM
+ if [ "$GOARCH" = "arm5" ]; then
+ export GOARCH=arm
+ export GOARM=5
+ fi
++ if [ "$GOARCH" = "387" ]; then
++ export GOARCH=386
++ export GO386=387
++ fi
+
+ # Build and vet everything.
+ # cmd/go/internal/work/exec.go enables the same vet flags during go test of std cmd