Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-02-27 16:54:25 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-02-27 16:54:25 +0100
commit7f2943784cd4eb44c94ac037418c666aaae09719 (patch)
tree97a609edb6fb264b41cadf4494279df4ad97d64f /build-support
parent7fb0b8b8192a5901b675c24ce5d363cc8c73befb (diff)
build-support/python-six-nocheck: removed Python 2
Diffstat (limited to 'build-support')
-rw-r--r--build-support/python-six-nocheck/PKGBUILD14
1 files changed, 2 insertions, 12 deletions
diff --git a/build-support/python-six-nocheck/PKGBUILD b/build-support/python-six-nocheck/PKGBUILD
index 82664eb9..4709e2ae 100644
--- a/build-support/python-six-nocheck/PKGBUILD
+++ b/build-support/python-six-nocheck/PKGBUILD
@@ -6,14 +6,14 @@
# heavily borrowed from python-six's PKGBUILD
pkgbase=python-six-nocheck
-pkgname=('python2-six-nocheck' 'python-six-nocheck')
+pkgname=('python-six-nocheck')
pkgver=1.15.0
pkgrel=3
pkgdesc="Python 2 and 3 compatibility utilities"
arch=('any')
url="https://pypi.python.org/pypi/six/"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
sha512sums=('eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9')
@@ -30,13 +30,3 @@ package_python-six-nocheck() {
python setup.py install --root "$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-package_python2-six-nocheck() {
- depends=('python2')
- provides=("python-six=$pkgver")
- conflicts=('python-six')
-
- cd six-$pkgver-py2
- python2 setup.py install --root "$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}